
EE322 Fall 2012 Lab 1: Intro to MATLAB  
 

Start up MATLAB on your computer. 
 
I. A Short Review of Linear Algebra 

 
The Basics ... MATLAB is short for “Matrix Laboratory”, so one of its basic premises is that 
the values we enter and operate on are matrices. A matrix is a two-dimensional array of 
values with a certain number of rows and a certain number of columns. If the matrix x has 13 
rows and 6 columns, we say that its dimensions are 13-by-6, or 13 ×  6. 
 
A vector is a matrix with only 1 row (a row vector), or with only 1 column (a column vector). 
For example, a vector may have dimensions 13 ×  1, or 1 ×  6. For example, the vector given 
by x = [ 3  -5  2.2  8] is a 1 ×  4 vector. 
 
A scalar is a matrix that has only 1 row and 1 column. For example, x = 3, or y = 4.332 each 
define a scalar. 
 
We can perform mathematical operations using matrices, as long as the matrix dimensions 
satisfy the following rules: 
 
1. You can only add or subtract matrices (or vectors) if their dimensions are the same. For 

example, you can add a 8 ×  4 matrix to an 8 ×  4, or subtract a 3 ×  1 vector from a 3 ×  
1 vector. The result is a matrix (or vector) of the same dimensions with values based on 
element-by-element addition or subtraction. 
 

2. When multiplying matrices together, they are usually of different dimensions, but their 
dimensions are important in determining whether the operation can be performed. You 
can multiply two matrices (or vectors) together ONLY if their inner dimensions are the 
same. For example, you can multiply an N ×  M matrix called “X” by an M ×  P matrix 
called “Y”. The result will be another matrix with dimensions N ×  P. 

 
If you multiply a 4 ×  1 vector by a 1 ×  4 vector, this results in a 4 ×  4 matrix. If you 
multiply a 1 ×  7 vector by a 7 ×  1 vector, this results in a 1 ×  1 matrix (which is a 
scalar). 
 
But, for example, you CANNOT multiply a 2 ×  3 matrix by a 7 ×  2 matrix, nor can you 
multiply a 1 ×  4 vector by a 1 ×  4 vector! 
 
This dimension mismatch will cause errors in MATLAB when you try it. This is 
probably the largest source of errors you will ever see as you use MATLAB! If you do 



see this error, in MATLAB you can check the size of the things you’re trying to multiply 
to determine the source of the error (more later). 
 
Run the following commands in MATLAB one at a time to see these dimension rules in 
action. The >> indicates the command prompt, so type the characters you see after the 
command prompt. 
 
Create some vectors called x and y: >> x=[1 2 3 4], y=[-1 1 4 8] 
Add the vectors to create z1:  >> z1=x+y 
Subtract the vectors to create z2: >> z2=x-y 
Try to multiply the vectors:  >> z3=x*y 
 
The last command caused an error because you’re trying to multiply a 1 ×  4 vector by a 
1 ×  4 vector. 
 

3. A matrix (or vector) is transposed by flipping the rows and columns. That is, the rows 
become the columns and the columns become the rows. For example, the transpose of 

matrix 3 4 1
8 0 2

⎡

⎣
⎢

⎤

⎦
⎥  is matrix 

3 8
4 0
1 2

⎡

⎣

⎢
⎢
⎢

⎤

⎦

⎥
⎥
⎥

. There are occasions where we will want to 

transpose matrices (more later). 
 
 
II. MATLAB Tutorial 
 
In many cases, you will be entering commands on the MATLAB command line. As mentioned 
before, what you type in the MATLAB command window will indicated by >> in the directions 
that follow. 
 
Suppose we want to create a 1 ×  4 row vector called “g” that has values 0.5, 1, 1.5 and 2. This 
can be created in MATLAB by typing. 
 
>> g=[0.5,1,1.5,2]  
 
or 
 
>> g=[0.5 1 1.5 2] 
 
These values can be samples of electrical current taken over 4 seconds.  Right now g is a row 
vector.  We could have input the values in the form of a column vector instead by typing ... 
 
>> g=[0.5 

1 
1.5 
2] 

 



or 
 
>> g=[0.5; 1; 1.5; 2] 
 
Here a carriage return or a semicolon is used instead of a comma to separate values.  Using rows 
or columns is irrelevant right now; you just have to follow the rules of linear algebra (ensuring 
dimensions are correct) when you want to operate on vectors.   
 
Suppose you want to plot the current versus time.  Type: 
 
 >> plot(g) 
 
The graph that appears may look right but what is actually happening is that the horizontal axis is 
not time; we haven’t defined the time variable yet.  The variable g is being graphed versus each 
element’s place in the vector, i.e., 0.5 is 1st, 1 is 2nd, 1.5 is 3rd and 2 is 4th.  We can define the 
time variable t by typing  
 
>> t=[0 1 2 3] 
 
or using the shortcut: 
 
>> t=0:1:3     
 
or even shorter: 
 
>> t=0:3.   
 
The outer numbers define the bounds on the range of t.  The inner number defines the spacing, so 
that t takes on the values 0, 1, 2, and 3.  If the inner number were 0.5, t would take on values 0, 
0.5, 1, 1.5, 2, 2.5, and 3.  This is almost twice as many values.  Now, to plot, the linear algebra 
rules are important: the vectors for g and t must be of the same length or size.  Type:  
 
>> plot(t,g)  
 
Also try  
 
>> plot(g,t)  
 
What’s the difference? The first vector supplied to the plot command is the x-axis variable 
(horizontal axis), and the second vector is the y-variable (vertical axis). Remember this fact: it is 
another common source of midshipman errors. 
 
Note that for any MATLAB script or function called “xxx”, you can type  
 
>> help xxx  
 
for an explanation on what it does and how to use it.  Type  
 
>> help plot  



 
as an example, to learn how the plot command can be used. 
 
Here is a common midshipman error: trying to access a value of a matrix or vector that is out of 
bounds. For example, consider the vector g above. To get the value of the 1st element of g, which 
is 0.5, and assign it to a new variable s, type 
 
>> s = g(1) 
 
However, you will get an error if you try to access the 0th element of g, or the 5th element of g, 
because the first element’s index is “1” (not “0” as in C or C++), and since g only has 4 
elements, g(5) doesn’t exist. Try these commands, and note the errors you get: 
 
>> g(0) 
>> g(5) 
 
The following exercises help you learn how to manipulate vectors and perform plotting in 
MATLAB. 
 
General vector manipulation 
 
At the MATLAB prompt, enter the following commands and note each result. Note that 
comments are identified with the “%” sign…when MATLAB sees this character, it ignores 
everything from the % sign to the end of the line of code. 
 
>>%This is a comment: use comments to explain what you’re doing. MATLAB  
>>% ignores everything on a line after the comment sign (%)…you don’t need  
>>% to include the comments that follow on the following command line  
>>% entries…they are just there to give you explanations. 
 
>>x=5 
 
>>x=10;     %The semicolon suppresses terminal output 
 
>>x     %Displays whatever values are stored in array x 
 
>>z=0:1:10 %This creates an 11-element vector…is it a row or column? 
 
>>z(1:3)    %Here are the first three elements of vector z 
 
>>zd5=z/5   %Divide each element of z by a scalar and call the result zd5 
 
>>zmpi=z*pi  %Multiply each element of z by pi=3.14159... 
 
>>zp3=z+3    %Add 3 to each element of z and call the result zp3 
 
>>a=z(1:3)./[5 2 10]   %Divide elements 1:3 of z by 5,2,10 respectively 
        %(this is element by element division) 
 
>>b=z(2:4).*[3 7 5]   %Multiply elements 2,3,4 by 3,7,5 respectively 
       %(this is element by element multiplication) 
 



>>z2=z.^2     %Square each element of the vector individually 
 
>>zhalf=sqrt(z) %Take the square root of each element 
 
>>zsin=sin(z) %Take the sin of each element of z (in radians, not degrees)  
 
>>zexp=exp(z) %Take e to the power of each element of z 
 
>>whos    % This will give a description of all the variables in your  
     % workspace, including how large they are 
 
>>a     % view the values of variable a 
 
>>b=a’    % take the transpose of a and call the result b 
 
>>a * b   % multiply vector a by vector b…can you do this? 
     % (dimensions ok)? 
 
>>a' * b   % multiply transpose of vector a by vector b…can you do this? 
     % (dimensions ok)? Does the result make sense? 
 
>>b * a'   % multiply vector b by transpose of vector a …can you do this? 
     % (dimensions ok?) Does the result make sense? 
 
 

Plotting and M-files 
 
Suppose you are testing a circuit element by applying voltages 1, 2, 3 and 4 V at times of 0, 2, 4, 
and 6 seconds, while reading current values of 0.5, 1, 1.5, and 2 Amps at the same times.  You 
want to use the voltages and currents to characterize the circuit element. 
 
MATLAB programs (also called “scripts”) or functions are stored as M-files (that is, they have 
the extension “.m”). MATLAB programs can be run by typing the name of the program at the 
command line (without the “.m”). Functions (such as plot, stored in an M-file called “plot.m”) 
require some input to make them run. Make a plot of v(t) after storing the following code into an 
M-file.  Open a new M-file by using the File→New→M-file pull down menu in MATLAB.  Type 
the following code into the window that pops up. The comments are there to explain steps…it is 
advisable to get into the habit of placing comments in your code to make it easier to determine 
what the commands are trying to do.   
 
v=1:4;     % voltage values: 1V, 2V, 3V, 4V 
i=0.5:0.5:2;   % current values: 0.5A, 1.0A, 1.5A and 2.0A 
t=0:2:6;     % times corresponding to v and i values: 0s,2s,4s,6s 
figure(1)    % for the following plots, use figure(1) 
plot(t,v)    % plot voltage vs time 
xlabel(‘time’)   % label the time axis (i.e., the x-axis) 
ylabel(‘voltage’)  % label the voltage axis (i.e., the y-axis) 
title(‘Voltage vs. Time’) % Overall title of the plot 
 
Save your M-file in the default directory that MATLAB started up in using the name lab1.m. 
When you tell MATLAB to run a function or program, that function or program must be in a 
folder that MATLAB knows about: that is, in MATLAB’s current directory, or in a folder in its 



path. Only if the program is in its path (or in the current directory) will MATLAB be able to run 
it. Remember this fact: it is another common source of midshipman errors. To view the 
MATLAB path, or to add a folder to its path (which you can always do), use the File→Set Path 
drop-down menu. Take a look at the MATLAB path using this drop-down menu. To run the 
program (or “script”) you just created, type  
 
>> lab1 
 
If you get in the habit of entering the code you wish to run in an m-file instead of just continually 
typing separate commands in the command window, you will find that you will operate more 
efficiently. It is much easier to simply edit the m-file then type the single command 
 
>> lab1 
at the command line, rather than reentering the 8 separate command that are contained in the file 
called lab1.m. Take note of this strong recommendation on how to code in MATLAB! 
 
If you are using one of the computers in Ri061 or another classroom and want to make sure you 
don’t lose the M-files you create, you will need to save these files on an external hard drive, CD, 
or if the computer is connected to the USNA network, email yourself the files. Remember: you 
CANNOT use a USB memory stick! 
 
Make a plot of power vs. time by adding the following lines into your lab1.m file: 
 
figure(2) % for the following plots, use a second figure labeled figure(2),  
    % so that figure(1) with the voltage plot is not written over 
p=v.*i; 
plot(t,p),xlabel(‘time’),ylabel(‘power’),title(‘Power vs. Time’); 
 

 
Plotting as specific functions of time 
 
Now suppose that the current is a function of time as given by, . 
 
To plot this for time between 0 and 20 sec (at 0.1 second intervals) add the following lines of 
code into your lab1.m file: 
 
clear    %To get rid of all the previous variable definitions 
t=0:.1:20;  %Make the step size small enough so that the plot looks smooth 
      % step size here is 0.1s 
amps=exp(-t/10); % for each value of t, a value of current will be computed 
      % Note: we do not use “i” for a variable, since it also is  
      % used for sqrt(-1), which we will use later. 
figure(3) 
plot(t,amps),xlabel(‘time’),ylabel(‘current’),title(‘Current vs. time’); 
 

Now from the figure (i.e., your plot) window, select the Tools→Edit Plot drop down menu. Now 
you can interactively change things about the appearance of the plot. Double click on the 
exponential curve and change the color and the width of the curve. Double click on the axes to 
change the x- and y-labels, etc.  



 
In many cases, it will be necessary to place plots you have created in lab reports or project write-
ups. This is easily done in MATLAB by copying and pasting your plot. From the figure (plot) 
window, select the Edit→Copy Figure drop down menu, which will allow you to paste it into a 
Word or PowerPoint document. 
 
Student Exercises: 
 
1.  Suppose you’ve measured currents of 0, 1.1, 2.05, 3.08, and 3.95 mA through a circuit 
element when voltages of 0, 1.00, 2.01, 3.00, and 4.05 V were applied.  Plot voltage versus 
current, and label the axes.  (Note that 1.1 mA may be typed as 1.1e-3 in MATLAB.) 
 
2.  Plot v(t)=20V sin(2π100t) for t between 0 and 20 ms. (You want the curve to look like a 
smooth sine wave so make sure you choose a small enough time step to give enough points 
between 0 and 20 ms; first try 1 ms, then try 1µsec…which looks better?) 
 
3.  Add a legend to this plot (type help legend to learn how to use the legend function). 
 
4.  Overlay 15e-100t on the existing figure (hint: use the hold function to plot on top of other 
plots…type help hold to learn how to use it). 
 
5.  Update the legend to reflect that there are 2 curves in this figure (rerun the legend command 
with both curves labeled). 
 
6.  If you print this figure you will not be able to distinguish one line from the other.  Make the 
sinusoid curve a solid black, and the exponential plot a dashed gray line. Choose one curve and 
make it have a thicker linewidth than the other curve. 
 
7.  Type grid. What changed? 
 
8.  Type grid again. What changed? 
 
9.  Can you move where the legend appears on the plot? 
 
10.  Investigate how the axis command works…type help axis and experiment. 
 
11.  Plot e-tcos(2πt) for t = 0 to 5 seconds. Ensure the time increment is small enough to get a 
smooth curve. 
 
12.  Add e-t to the existing figure as a dotted green line. 
 
13.  Add a legend, axes labels, and a title to the figure. Print out and turn in this figure…your lab 
report for this lab will be made up solely of this printout. You should include your name in the 
title command for the figure so you can tell your printout from someone else’s. 
 



14. The following code is an example of a MATLAB function. This would be contained in an M-
file called “funct1.m”. What does this function do? Create this function as an M-file, save it and 
find the result if a=5 and b=12. Type >>help funct1 at the command line and observe the 
result. What do the comments immediately after the function line do? 
 
function y = funct1(a,b) 
% function y = funct1(a,b) 
%  This function takes two positive-valued scalar inputs and gives 
%  a scalar output. If the inputs are not both positive, an error is 
%  displayed. 
 
if (a < 0) | (b < 0)  % Note: the “|” is the “or” operator, as in C++ 
  disp(‘Warning: One or both inputs are < 0’) 
end 
y=sqrt(a^2 + b^2); 
 

 For more general information on functions, type help function. 
 
15.  Use the example function in problem 14 to create a new function that performs the 
following: given input integer N, it will compute the sum of the integers from 0 to N. Your 
function should work for arbitrary positive integer values of N only. It should test if the input is 
positive, and if it is an integer and give an error if not. Hint: to test if a value is an integer, you 
can use an “if” statement as in: if (round(N) ~= N), where N is the value that is input to the 
function, round is the existing MATLAB function that rounds its input to the nearest integer, and 
~= is the “not equals” symbol. Type help if if you need more information on how to use the if 
command. Save this function in an m-file called sumN.m. 
 
16.  Another problem that midshipmen sometimes have in MATLAB is that they name their 
variables or m-files the same name as an existing MATLAB function. This will take you’re your 
ability to use the MATLAB function until it is cleared up. Here’s how it can happen. Type the 
following lines of code: 
>> x=[1 2 3] 
>> mean=mean(x) % Creating a new variable called “mean” which is 
     % the average value of variable x. This uses the MATLAB  
     % “mean” function. 
>> mean(x)   % Now trying to display the mean value of x using the  
     % MATLAB “mean” function, which is no longer available… 
     % MATLAB spits out an error. 
>> clear mean  % This clears the variable called “mean” in the workspace, 
     % which allows the “mean” function to be used again. 
>> mean(x)   % The correct mean value is displayed. 
 
 
Summary of important points: see the MATLAB Tidbits for Mids handout. 
 


