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Date:

SP211 Lab Exercise #1: One Dimensional Kinematics
Part I. Pre-Lab Homework Problem

A. Consider the following situation:

At time =0, you are at rest at x = 1.0 m.

Att=1.0s, you begin walking away from origin with constant speed 1.0
m/s.

Att=3.0s, you stop.

Att=6.0 s, you begin walking toward origin with constant speed 0.5 m/s

Att=28.0 s, you stop, and

Att=9.0 s, the experiment ends.

Sketch graphs of x vs ¢, of v vs ¢, and of a vs ¢ for this situation, for 0 <7 <10 s.
To facilitate comparison, please use the same time scale for all three graphs, and align the
vertical axes.

B. At =0 in this situation, a dynamics cart is at rest at position x = 0.25 m. At time ¢ =
1.0 s, the cart begins to accelerate with constant acceleration 0.1 m/ s*>. The cart is
stopped abruptly at =6 s.

Sketch graphs of a vs 7, of v vs ¢, and of x vs ¢ for this situation, for 0 <7 < 8.
As in part (A) above, please use the same time scale for all three graphs, and align the
vertical axes.
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I. Introduction

A. Since Physics is the study of how the world around us works, many Scientists have
conducted experiments and analyzed the data to determine the mathematical
relationships that described the phenomenon they observed.

B. In the digital age, the use of a computer to obtain and record the data is most
advantageous. A device that communicates between the data acquisition module and
the laptop is called an input/output (I0) interface (or interface for short). Sometimes
itis just called an 10 device too.

C. In all of the Physics Labs for both SP211 and SP212, the Lab-Pro interface device is
often used to communicate with various sensors and display their output graphically
in the Logger-Pro program.

D. Graphical analysis is a widely used technique in physics to convey information
visually. As a consequence, it is important that the student becomes very familiar
with graphs in general; in particular during the labs, how to manipulate the Logger-
Pro program to display accurate graphs that convey meaning.

E. The main purpose of this laboratory, besides familiarization with lab equipment and
procedures, is to create and use a graphical representation of 1D motion to reinforce
the 1D Kinematics concepts within an experimental study.
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II. Objectives

At the end of this activity, you should:
1. Have the Logger-Pro program installed on your personal laptop.

2. Be able to connect sensors to the Lab-Pro interface and find them in the Logger-Pro
program (calibration of a device will be shown in future labs.)

3. Be able to create and fully label a position, velocity, and acceleration graphs in the
Logger-Pro program (if necessary, be able to delete existing and/or add additional
graphs.)

4. Be able to discuss the relationship between the position, velocity, and acceleration
graphs.

5. Be able to re-scale a graph (both auto-scale and manually.)

6. Be able to use “Linear Fit” and/or “Statistics” functions in LoggerPro and understand
why and when to use each (i.e to help describe phenomena such as slope.)

7. Understand when “Curve Fit” is appropriate and fit a quadratic curve to your data.

8. (Time Permitting) Be able to discuss uncertainty and discuss how uncertainty
calculations are conducted during Physics Laboratories. Be familiar with Uncertainty and
the uncertainty associated with LoggerPro and be able to discuss how it pertains to 1D
Kinematics.

9. (Time Permitting) Be able to execute any other function your particular instructor
deems essential to completing assigned laboratories this semester.
Note: Any of the Objectives not completed during this lab will be discussed as used in future
laboratories.

Ill.Needed Equipment

A. Laptop, Logger-Pro Installation procedure handout, Printer Instruction
Handout, LabPro Interface (including USB cable), PASCO Motion Sensor
II, PASCO Force Sensor, Uncertainty “rules of thumb” handout, a 12inch
ruler, a meter-stick, a “rubber ball”, and a pencil/pen.

IV.Turn in your Pre-lab/homework problem if assigned.
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V.

A.

Procedure

Download and install the Logger-Pro software following the instructions handout
given to you by your instructor.

1.

3.

4.

Note: It is important to follow the instruction as explicitly written in order to
optimize the installation process.

Note: NEVER try to run the install any software directly from the USNA Software
Downloads page! It not only will bog down the network, but might also lead to
unforeseen errors. Download it to your desktop first.

Notify your instructor if you receive any errors during the installation process.

Do not proceed to the next step until all errors are resolved.

If no errors were received during the installation process, start the logger-pro
program by double clicking on the Logger-Pro 3.8.5.1 icon.

1.

What you should see is a generic x vs. y graph and columns for data sets labeled x
and y. Directly above the data set columns you should notice it says “No device
connected.” This is because we have not yet connected the interface.

Now connect the LabPro interface as shown below.
- L.abPro Interface Box

USB connection
near Ethernet

Port \

Laptop

Plug into Outlet
a. Use the USB connection next to the Ethernet port. This connection

optimizes the communication between the LabPro interface and the
Logger-Pro program.

Page 3 of 13



SP211 Lab: One = Introduction to Lab and 1D Kinematics
Version: August 15, 2013

b. Anicon of the interface device should appear where before it said “No
device connected.” Most interfaces will now have a flashing green LED to
signify that the device is working and it is actively searching for a sensor to
communicate with.

3. Connecting a sensor:
a. Next we will connect the PASCO Motion Sensor II.

1) Connect the motion sensor to the LabPro device as shown below. Use
Dig/Sonic 2 port. (We are purposely installing the device into the non-
default port so that you will be forced to tell the interface which port you
are plugged into.) For future labs, you may choose to plug into the default
port unless your instructor or the lab instructions tell you differently.

L.abPro Interface Box 2
Motion Sensor (MS)

2) Notice: The green LED on the motion sensor is not yet lit. This is because
the sensor and the interface are not yet communicating. We must now
setup the sensor in Logger-Pro so that the interface device knows what
sensor is connected and where to look for it.

4. “Set Up Sensors”

a. Now move your cursor over and click on the word Experiment in the top left
corner of the screen. You should see a table expand. Now slide down to “Set
Up Sensors.” Another expanded table should appear. Select “Show All
Interfaces.”

b. You should now see a picture of the LabPro device (most likely oppositely
oriented from yours). Itis specifically showing you all the ports. There are 4
analog connection ports labeled CH-1 through CH-4. In addition there are two
digital connection ports labeled Dig/Sonic 1 and Dig/Sonic 2. It also shows
you the Operating System (0S) version and tells you the status of your battery
in the interface. On the far left and right it shows you the many different
sensors of each type that you could possibly connect.
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C.

To connect our motion detector, left click on the arrow next to Dig/Sonic 2. An
expanded table should pop up with “Choose Sensor” displayed. Slide the
mouse over and down and select by left clicking on “Motion Detector.”

The green LED on the motion detector should start flashing immediately and
you might hear an audible clicking sound. This device detects position through
a novel application of the same technology found on our most sophisticated
submarines: sound ranging or SONAR. (Of course, in the case of submarines,
the sound travels through water not air.) Sound pulses are emitted through
the gold-colored membrane on the front of the sensor. These pulses travel
through the air until they come into contact with an object. When a sound
pulse bounces off the object and returns to the motion sensor (MS), the system
(computer/LoggerPro, LabPro, and MS) compares the emitted and received
pulses and calculates the position of the object relative to the sensor (the
origin).

¢ Note: When the MS successfully locks on target, the tiny green light on the front of the MS
illuminates.

e. Position determination is carried out frequently (20 times/second by default)

so that the position can be measured at closely spaced time intervals.
Consequently, displacement, velocity, and acceleration can be calculated from
the change in position, change in position vs time, and change in velocity vs
time, respectively. We will study these quantities in later labs.

On the top of the MS is a small, black switch that enables you to choose
between a narrow or wide sonar beam. These settings are described on the
back of the MS. Use of the narrow beam reduces clutter but has a short range
of about 2 meters. The wide (or standard) setting gives long-range detection
out to about 8 meters but is, of course, more susceptible to unwanted signals
(reflections). The dial on the side of the device allows one to rotate the
detector up and down.

* Note: The MS will detect anything in its range. It is important to keep the path to the object of
interest clear, i.e., keep books, other people, etc out of the path of the beam of the MS.
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5. Adding an additional sensor:

a.

Although we are not going to specifically use the force sensor in today’s lab we
need to be able to connect additional sensors from time to time in our physics
labs. Today we will add the force sensor so that we know how to add
additional sensors.

P,‘{.‘;L'() Force Sensor.

Add the force sensor by first connecting it into CH-3 port (Again, we are
purposely installing the device into the non-default port so that you will be
forced to tell the interface which port you are plugged into.) For future labs,
you may choose to plug into the default port (unless your instructor or the lab
instructions tell you differently.)

If the “Show All Interfaces” screen is no longer on the screen, move your
cursor over the word Experiment in the top left corner of the screen. You
should see a table expand. Now slide down to “Set Up Sensors.” Another
expanded table should appear. Select “Show All Interfaces.”

To connect our force sensor, left click on the arrow next to CH-3. An expanded
table should pop up with “Choose Sensor” displayed. Slide the mouse over
twice and down over the word “Force” then over and down and select by left
clicking on “Duel Range Force.”

Close the “Show All Interfaces” screen by clicking on the “Red X".

6. You should notice that you have 3 graphs on your screen: Position, Velocity, and
Force. Since we are not going to be using the force sensor the rest of this lab
disconnect the sensor at this time by removing the plug from CH-3.

a.

b.

Then right click on the force graph and select delete.

As you can see you can delete graphs that you do not desire.
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7. Now we want to verify that we understand all the processes discussed above. So
go up to the left hand portion of the screen and select “File” then slide down and
select “New.” DO NOT SAVE anything.

a.

Add the motion sensor as previously discussed in section 4. Close the “Show
All Interfaces” screen by clicking on the “Red X".

One short cut to get to the “Show all Interfaces” screen is to click on the icon of
the LabPro above the “Latest Data” columns.

So that we can learn how to install additional graphs, manually delete the
velocity graph by right clicking on it and selecting delete.

8. Inserting Additional Graphs:

a.

To add additional graphs click on “Insert” in the upper left of the screen. Slide
down to “Graph” and select.

The graph that appears on the screen is an acceleration graph, but we want a
velocity graph. To change the type of graph, place your cursor over the word
Acceleration and then left click. Select the type of graph you want. In this case
we want a Velocity graph. To arrange the graphs nicely, go up to “Page” near
the top middle of the screen. Select “Page” then slide down and select “Auto
Arrange.”

9. Sometimes, your instructor might choose to use pre-loaded templates in which all
the setup work is already completed so that students can jump right in to taking
data.

If instructed by your instructor, download the templates from the IRC’'s USNA Software Download’s page
where you downloaded the LoggerPro program. Place them in a folder labeled SP211 Labs on your

desktop.

Extension CMBL is a file that can be double clicked on to open LoggerPro and the template at the same time.

Extension XMBL is a file format that can only be opened from the LoggerPro program.

Note: When using LoggerPro, please do not save over any of the preprogrammed experiment files. If it would be useful to save the
data, choose the SAVE AS option under the File menu and save the data under a new file name. (For example, use your last name
and the date.) When closing experiment files, you will be asked if you would like to save the changes to the file. Always click on NO.
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C. Recurring steps:
Using Logger Pro to program the LabPro: Know as the “Three Steps”

® Experiment -> Set Up Sensors -> Show all Interfaces: Make sure all the right sensors
show up in all the right holes.

® Experiment -> Data Collection: Set the length of time data is to be taken and the rate
at which data is to be taken.

® File -> Settings for...: Check the checkbox to Show Zero on Toolbar, and make sure
number of points for Derivative and Smoothing are both 7.

D. Ask your instructor which experiments he or she would like you to
conduct today and then proceed to those applicable steps as
appropriate.

E. Experiment 1: Walking To and Fro: Position and Velocity

1. Follow the Three Steps in Logger Pro to program the LabPro to take data for
position and velocity as functions of time appropriately for this experiment.

Note: The MS will detect anything in its range. It is important to keep the path to the object of
interest clear, i.e., keep books, other people, etc out of the path of the beam of the MS.

2. Take data for the position of your own body as you:

a. Place the MS on the edge of the lab table and set the selector switch to Standard (the
wide beam). Point the MS into an aisle or some area that will give you or your lab
partner room to walk.

b. The person being the experiment will stand about 12 inches from the detector and
when told by the data collector (after the data collector clicks on the green “Collect”
button near the top middle of the page) she/he will walk away from the detector and
back toward the detector. Try for today’s lab to walk at a steady pace.

c. Stand motionlessly for a second or two, then

d. Walk slowly away from the Motion Detector at a steady speed, then
e. Stand motionless for a second or two, then

f. Walk rapidly toward the MD at a steady speed, and then

g. Finally stand motionlessly for a second or two.

If you are not satisfied with your graph you might choose to take a few practice tries.
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3.

5.

Scaling a plot:
a. There are two ways to scale a plot, automatically and manually.

b. To scale automatically, right click on the axis of your choice and then slide
down to “Autoscale,” you will be given the choice of “Autoscale” or “Autoscale
From 0.” Autoscale from zero is frequently the correct choice, but clearly not
always; which you choose depends on the experiment you are conducting or
the meaning you are trying to communicate to your reader. Try each and see
their effect on your graph.

c. To scale “Manually,” right click on an axis and select “Graph Options” then
select the “Axes Options” tab. Make changes to items on this tab and see their
affects too.

d. Itisimportant to label the graph with the information that it represents. The
best way to label the graph is to modify its title. This can be done many
different ways, but the easiest is to right click on the graph, and select “Graph
Options” then select the “Graph Options” tab. You will easily find the title area.
Title your graph appropriately.

In the Position ys Time graph, find the average velocity for each of the time
periods a - e above. Use Analyze -> Linear Fit to do this.

In the Velocity vs Time graph, find the average velocity in each of the same
regions. Use Analyze -> Statistics.

Annotate, print, and, in a short paragraph, compare the two different methods of
measuring the average velocity in this experiment. Do they agree? Explain.

F. Experiment 2. Walking To and Fro: Velocity and Acceleration

1.

Use the same data from Experiment 1, above. Close all the Statistics and Linear Fit boxes.
Change the vertical axes from Position and Velocity to Velocity and Acceleration.

In the Velocity vs Time graph, find the average acceleration for each of the five time
periods in Parts B.2.c - g. Use Analyze -> Linear Fit.

In the Acceleration vs Time graph, find the average acceleration in each of the same
regions. Use Analyze -> Statistics.

Annotate, print, and, in a short paragraph, compare the two different methods of
measuring the average acceleration in this experiment. Do they agree? Explain.

When do we use "Linear Fit" to find the average of an observable, and when do we use
"Statistics?"
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G. Experiment 3. Uniformly Accelerated Motion

1. Raise one end of the track so that you have a ramp. Make sure you have Logger
Pro set to show graphs for the position, velocity and acceleration of the cart.

2. Hold the cart still. Start taking data. Wait a second; then launch the cart up the
ramp as your instructor demonstrates. Take data while the ramp starts up the
ramp, slows to a stop, than accelerates back down the ramp. Be careful! These
carts cost $80!!

3. In the Position vs Time graph, use Analyze -> Curve Fit to fit a quadratic to your data,
and find the cart's average acceleration.

4. In the Velocity vs Time graph, use Analyze -> ... which one should it be? ... to find
the cart's average acceleration.

5. Inthe Acceleration ys Time graph, use ... which one???? ... to find the cart's average
acceleration.

6. Annotate, print, and, in a short paragraph, compare the three methods of finding
average acceleration in this experiment. Do they agree? Explain.

H. Experiment 4. Position, velocity, and acceleration for a Bouncing Ball

1. Either you or your lab partner holds the MS about chest height and ensure to set
the selector switch to Standard (the wide beam). Point the MS down toward the
ground.

N

With your other hand, after you coordinate with your lab partner to start
collecting data in Logger-Pro (Lab partner presses collect and gives you the go
signal), release the rubber ball and allow it to gently fall to the ground. Try to
maintain the motion sensor over the ball, but you DO NOT have to track the ball in
the up and down direction, only if the ball moves left or right.

3. In the Position yvs Time graph, use Analyze -> Curve Fit to fit a quadratic to your data,
and find the ball's average acceleration. Remember your position graph will have
opposite coordinates than the graph on the first page of this procedure due to how you
are holding the motion sensor.

4. In the Velocity vs Time graph, use Analyze -> ... which one should it be? ... to find
the balls's average acceleration.

5. Inthe Acceleration vs Time graph, use ... which one???? ... to find the ball's average
acceleration.

6. Annotate, print, and, in a short paragraph, compare the three methods of finding
average acceleration in this experiment. Do they agree? Explain.
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4. Printing a plot:

a.

Follow the instructions on the printer instructions handout to map the printer
for the lab room.

. If you receive any errors, immediately notify your instructor so

that they may be resolved.

If no errors, then print your graph to ensure that you will be able to print for
future labs. Save your graph as it might be a useful reference when you
conduct Lab 1 next week.

Ask you instructor if she/he wants you to continue with the LAB or proceed to
section VIII (cleanup).

VL. (Time Permitting) Uncertainty and Regression Lines

A. Read the Handout from your instructor about uncertainty and answer the following
questions:

1.

Measure the desk using a 12inch ruler. Record the measurement including
the uncertainty.

Now make the same measurement using a meter stick. Record the
measurement including its uncertainty.

Now determine the area of the table. Record each measurement and show the
calculation for area including its uncertainty. Hint: How does the uncertainty
of each measurement affect the area uncertainty?

As you can imagine, calculations can get more complicated than simple
multiplication. Read the handout and then discuss how you would use the
uncertainties of each measurement to determine the density of a brass
cylinder. Discuss now how you would compare your calculated answer to that
of the actual known density of brass to see if you were accurate and/or precise
or neither.

Ask your instructor if she/he wants you to continue with the LAB or proceed
to section VIII (cleanup).
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B. Calculate the slope of your position graph by hand and then have LoggerPro do it for

C.

VII.

you. In order to have the computer calculate the slope, you first select the portion of
the curve to be analyzed by clicking and dragging the mouse from left to right so that
the cursor in the LoggerPro window traverses the data to be fit. If you are successful,
a shaded area will cover the data to be analyzed on the computer screen. After
selecting the portion of the data to be fit, click on Analyze in the menu of the
LoggerPro window. From the menu that appears, choose Linear fit and the “least
squares,” best-fit straight line should appear on the LoggerPro window along with the
slope and intercept.

1. The uncertainty in the slope is not quite as easy to estimate as the uncertainty

in a single measurement. One approach is to estimate what the largest and
smallest possible slopes are by eye. Alternatively, the computer can give an
estimate of the uncertainty. It can calculate the standard deviation of the
slope and the intercept, and for the purpose of this course, one can use these
as the uncertainties. To have the computer display the uncertainties, double-
click on the box showing the fit parameters for the graph in the LoggerPro
window. Linear Fit Options will appear. Selecting "Show Uncertainty" for
both the "Slope" and "Y-Intercept,” and then clicking the OK button will
display these parameters.

Ask your instructor if she/he wants you to continue with the LAB or proceed
to section VIII (cleanup).

At this time, your particular instructor might present to you other functions in
Logger-Pro that are essential to completing future labs in your class. Seek guidance
from your instructor on which processes to complete at this_time. If there are no
other processes to be discussed proceed to section VIII (cleanup).

Lab Report to Hand In (only graphs as assigned based on your
instructor’s input)

Graph from Part E, Experiment 1, annotated and with discussion.
Graph from Part F, Experiment 2, annotated and with discussion.
Graph from Part G, Experiment 3, annotated and with discussion.

Graph from Part H, Experiment 4, annotated and with discussion.
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VIII. Clean-Up

A. Golden Rule: “Do unto others as you expect them to do unto you.” This applies as
much here in the lab as it does in the Fleet. As future Naval Officers, how can you
expect your enlisted sailors to maintain a clean work area if your stateroom, work
areas, mess area, etc is a “pig sty?” So as officers it is imperative that we clean up
after ourselves not only to follow the Golden Rule, but also to lead by example for the
enlisted folks under our charge.

1. End of Lab Checkout: Before leaving the laboratory, please tidy up the
equipment at the workstation and quit all running software.

2. The lab station should be in better condition than when you arrived and more
importantly, should be of an appearance that you would be PROUD to show to
your legal guardians during a “Parents Weekend.”

3. Have your instructor inspect your lab station and receive their permission to
leave the Lab Room.

4. You SHALL follow this procedure doing every lab for BOTH SP211 and SP212!

Page 13 of 13



