Objectives

Adobe® InDesign is a professional design and layout software that lets you design and produce engaging documents for print or digital distribution. Integrate interactivity, video, and audio for playback on tablets, smartphones, and computers. After this workshop, you should be able to:

- Become familiar with the InDesign interface
- Create an InDesign document
- Manage pages and spreads
- Add/Edit Text and Text Frames
- Import Graphics
- Export Document
Table of Contents

Objectives ........................................................................................................................... 2

Table of Contents ................................................................................................................ 3

InDesign Workspace ........................................................................................................... 4

Different Viewing Modes ................................................................................................... 5

Toolbox Overview .............................................................................................................. 6

Create a New Document ..................................................................................................... 7

Managing Pages and Spreads ............................................................................................ 9

Add Text and Text Frames ............................................................................................... 13

Import Graphics ................................................................................................................ 19

Export Document .............................................................................................................. 23
InDesign Workspace

Before you start creating an InDesign document, you should get yourself familiar with the InDesign workspace.

- **The Tools panel** contains tools for creating and editing images, artwork, page elements, and so on. Related tools are grouped.

- **The Control panel** displays options for the currently selected tool.

- **The Document window** displays the file you are working on. Document windows can be tabbed and, in certain cases, grouped and docked.

- **Panels** help you monitor and modify your work. Panels can be grouped, stacked, or docked.

- **Pasteboard** is an area outside a page where you can store objects that aren’t yet positioned on a page.
Different Viewing Modes

You can change the visibility of the document window using the Mode buttons from the Application bar across the top of the screen. Alternatively, you can select from the “View > Screen Mode” menu.

- **Normal Mode:** Displays artwork in a standard window with all visible grids and guides showing, non-printing objects showing, and a white pasteboard.

- **Preview Mode:** Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects), and the pasteboard set to the preview background color defined in Preferences.

- **Bleed Mode:** Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects), the pasteboard set to the preview background color defined in Preferences, and any printing elements within the document's bleed area (defined in Document Setup) showing.

- **Slug Mode:** Displays artwork as if it were output, with all non-printing elements suppressed (grids, guides, non-printing objects), the pasteboard set to the preview background color defined in Preferences, and any printing elements within the document's slug area (defined in Document Setup) showing.

- **Presentation Mode:** Displays artwork as if it were a slideshow presentation, with no menus, panels, or tools displayed.
Toolbox Overview

The Toolbox panel includes tools for selecting, editing, creating page elements, and choosing type, shapes, lines, and gradients.

Select a tool from the default toolbox by clicking it. The toolbox also contains several hidden tools related to the visible tools. Hidden tools are indicated by arrows to the right of the tool icons. Select a hidden tool by clicking and holding the current tool in the toolbox and then selecting the tool that you want. The name of the tool and its keyboard shortcut appear when you hold the pointer over the tool.

![Toolbox overview diagram]

- **Selection tools**
  - Selection (V, Escape)*
  - Direct Selection (A)
  - Page (Shift + P)
  - Gap (U)
  - Content Collector (B)
  - Content Placer

- **Drawing and Type tools**
  - Type (T)
    - Type On a Path (Shift + T)
  - Line (L)
  - Pen (P)
    - Add Anchor Point (=)
    - Delete Anchor Point (-)
    - Convert Direction Point (Shift + C)
  - Pencil (N)
    - Smooth
    - Erase

- **Transformation tools**
  - Scissors (C)
  - Free Transform (E)
  - Rotate (R)
  - Scale (S)
  - Shear (O)
  - Gradient Swatch (G)
  - Gradient Feather (Shift + G)

- **Modification and Navigation tools**
  - Note
  - Eyedropper (I)
  - Measure (K)
  - Hand (H)
  - Zoom (Z)

* Indicates default tool  * Keyboard shortcuts appear in parenthesis
Create a New Document

To create a new document:

1. Go to “File > New > Document”

2. You will see the “New Document” dialogue box.
New Document options

- Document Preset: Choose a preset that you have saved earlier.
- Number of pages: Specify the number of pages to create in the new document.
- Start Page #: Specify which number the document starts on.
- Facing Pages: Select this option to make left and right pages face each other in a double-page **spread**, such as for books and magazines. Deselect this option to let each page stand alone, such as when you are printing flyers or posters or when you want objects to **bleed** in the binding.
- Master Text Frame: Select this option to create a text frame the size of the area within the margin guides, matching the column settings you specified. The master text frame is added to the A-Master.
- Page Size: Choose a page size from the menu, or type values for Width and Height. Page size represents the final size you want after bleeds or other marks outside the page are trimmed. Note: The default measurement units are picas (a pica equals 12 points, 16 pixels).
- Orientation: choose between “Portrait” or “Landscape”.

More Options

Click “More Options” in the “New Document” dialog box to specify the dimensions of the bleed and slug areas. To make the bleed or slug areas extend evenly on all sides, click the “Make All Settings The Same” icon.

- Bleed: The Bleed area allows you to print objects that are arranged at the outer edge of the defined page size. For a page of the required dimensions, if an object is positioned at its edge, some white may appear at the edge of the printed area due to slight misalignment during printing or trimming. For this reason, you should position an object that is at the edge of the page of the required dimensions a little beyond the edge, and trim after printing. Bleed area is shown by a red line on the document. You can set bleed area settings from Bleed in the Print dialog box.

- Slug: The slug area is discarded when the document is trimmed to its final page size. The slug area holds printing information, customized color bar information, or displays other instructions and descriptions for other information in the document. Objects (including text frames) positioned in the slug area are printed but will disappear when the document is trimmed to its final page size.
Managing Pages and Spreads

Pages and Spreads

Document pages are arranged in spreads. A spread is a set of pages viewed together, such as the two pages visible whenever you open a book or magazine.

The Pages Panel

The Pages panel provides information about and control over pages, spreads, and masters (pages or spreads that automatically format other pages or spreads). By default, the “Pages” panel displays thumbnail representations of each page’s content. If the “Pages” panel isn’t visible, click on the “PAGES” button on the right side of the screen. Alternatively, you can choose “Window > Pages” to open the “Pages” panel.

Target or Select a Page or Spread

Targeting makes a page or spread active. In the “Pages” panel:

- To both target and select a page or spread, double-click its icon or the page numbers under the icon. If the page or spread is not visible in the document window, it shifts into view.
- To select a page, click its icon. (Don’t double-click unless you want to select it and move it into view.)
- To select a spread, click the page numbers under the spread icon.
Add Pages

To add new pages to a document, do any of the following:

- To add a page after the active page or spread, click the “New Page” button in the “Pages” panel or choose “Layout > Pages > Add Page”. The new page uses the same master as the existing active page.

- To add multiple pages to the end of the document, choose “File > Document Setup”. In the “Document Setup” dialog box, specify the total number of pages for the document. InDesign adds pages after the last page or spread.

- To add pages and specify the document master, choose “Insert Pages” from the “Pages” panel menu or choose “Layout > Pages > Insert Pages”. Choose where the pages will be added and select a master to apply.
Move, duplicate, and delete pages and spreads

You can use the “Pages” panel to freely arrange, duplicate, and recombine pages and spreads. Keep the following guidelines in mind when adding, arranging, duplicating, or removing pages within a document:

- InDesign preserves the threads between text frames.
- InDesign redistributes pages according to how the “Allow Document Pages To Shuffle” command is set.
- An object that spans multiple pages stays with the page on which the object’s bounding box covers the most area.

Move pages

You can move pages by using “Move Pages” command:

1. Choose “Layout > Pages > Move Pages,” or choose “Move Pages” from the “Pages” panel menu.
2. Specify the page or pages you want to move.
3. For “Destination,” choose where you want to move the pages, and specify a page if necessary. Click “OK”.

Alternatively, you can move pages by dragging a page icon to a new position within the document in the Pages panel. As you drag, the vertical bar indicates where the page will appear when you drop it.

Duplicate a page or spread

In the Pages panel, do one of the following:

- Drag the page range numbers under a spread to the “New Page” button. The new spread appears at the end of the document.
- Select a page or spread, and then choose “Duplicate Page” or “Duplicate Spread” in the “Pages” panel menu. The new page or spread appears at the end of the document.
- Press Alt (Windows) or Option (Mac OS) as you drag the page icon or page range numbers under a spread to a new location.
Delete a page or spread from the document

Do one of the following:

- In the “Pages” panel, drag one or more page icons or page-range numbers to the “Delete” icon.

- Select one or more page icons in the “Pages” panel, and click the “Delete” icon.

- Select one or more page icons in the “Pages” panel, and then choose “Delete Page(s)” or “Delete Spread(s)” in the “Pages” panel menu.

Create a Multiple-page Spread

1. Do one of the following:

   a. To keep a single spread together, select a spread in the “Pages” panel, and then deselect “Allow Selected Spread To Shuffle” in the “Pages” panel menu. You can identify an island spread in the “Pages” panel by the brackets around its page numbers.

   b. To allow the creation of spreads of more than two pages in the entire document and to preserve those spreads when you add, remove, or arrange preceding pages, deselect “Allow Document Pages To Shuffle” on the “Pages” panel menu. InDesign will preserve spreads of more than two pages while letting two-page spreads repaginate normally.

2. Add pages to the selected spread either by using “Insert Pages” to insert a new page in the middle of a spread or by dragging an existing page to the spread in the “Pages” panel. To drag an entire spread, drag its page numbers.

Master Pages

A master is like a background that you can quickly apply to many pages. Objects on a master appear on all pages with that master applied. Master items that appear on document pages are surrounded by a dotted border. Changes you make to a master are automatically applied to associated pages. Masters commonly contain repeating logos, page numbers, headers, and footers. They can also contain empty text or graphic frames that serve as placeholders on document pages. A master item cannot be selected on a document page unless the master item is overridden.

Create masters

By default, any document you create has a master page. You can create additional masters from scratch or from an existing master page or document page.
Add Text and Text Frames

Create Text Frames

Text in InDesign resides inside containers called **text frames**. Text frames can be moved, resized, and changed. Use the “Selection” tool for general layout tasks such as positioning and sizing a frame.

Text frames can also be connected to other text frames so that the text in one frame can flow into another frame. Frames that are connected in this way are **threaded**. Text that flows through one or more threaded frames is called a **story**. Text frames can have multiple columns. Text frames can be based on, yet independent of, page columns.

To create a text frame, do any of the following:

- Select the “Type” tool, and then drag to define the width and height of a new text frame. Hold down “Shift” as you drag to constrain the frame to a square. When you release the mouse button, a text insertion point appears in the frame.

- Use the “Place” command to place a text file.

- Using the “Type” tool, click inside any empty frame. If the “Type Tool Converts Frames To Text Frames” option is selected in “Type” preferences, the empty frame is converted to a text frame.

Add Text to a Document

You can add text to a document by typing or by pasting or placing text from a word-processing application. If your word-processing application supports drag-and-drop, you can also drag text into InDesign frames. When you place or paste text, you do not need to create a text frame first; InDesign will create one for you automatically.
**Type text in a document**

Do one of the following:

- Using the “Type” tool, drag to create a new text frame, or click in an existing text frame.

- Using a “Selection” tool, double-click inside an existing text frame. The “Type” tool is selected automatically.

**Paste text**

If the insertion point is not inside a text frame when you paste text into InDesign, a new plain text frame will be created. If the insertion point is inside a text frame, the text will be pasted inside that frame. If you have text selected when you paste, the pasted text will overwrite the selected text.

**Paste text from another application**

- To preserve formatting and information such as styles and index markers, open the “Clipboard Handling” section of the “Preferences” dialog box, and select “All Information” under “Paste”. To remove these items and other formatting when pasting, select “Text Only”.

- Cut or copy text in another application or in an InDesign document.

- If you like, select text or click in a text frame. Otherwise, the text will be pasted into its own new frame.

- Do one of the following:
  
  o Choose “Edit > Paste”. If the pasted text doesn’t include all the formatting, you may need to change settings in the “Import Options” dialog box for RTF documents.

  o Choose “Edit > Paste Without Formatting”. (“Paste Without Formatting” is dimmed if you paste text from another application when “Text Only” is selected in “Clipboard Handling” Preferences.)

**Drag and drop text**

You can use the mouse to drag and drop text in the “Layout View”. You can also copy text or create a new frame when dragging and dropping text.

1. To enable drag and drop, choose “Edit > Preferences > Type” (Windows) or “InDesign > Preferences > Type” (Mac OS), select “Enable in Layout View,” and
then click OK.

2. Select the text that you want to move or copy.

3. Hold the pointer over the selected text until the drag and drop icon appears, and then drag the text. As you drag, the selected text remains in place, but a vertical bar indicates where the text will appear when you release the mouse button. The vertical bar appears in any text frame that you drag the mouse over.

4. Do any of the following:

   • To drop the text in a new location, position the vertical bar where you would like the text to appear and release the mouse button.

   • To drop the text in a new frame, hold down “Ctrl (Windows)” or “Command” (Mac OS) after you start dragging, and then release the mouse button before releasing the key.

   • To drop the text without formatting, hold down “Shift” after you start dragging, and then release the mouse button before releasing the key.

   • To copy the text, hold down “Alt (Windows)” or “Option” (Mac OS) after you start dragging, and then release the mouse button before releasing the key.

**Place (import) text**

When you place a text, you can specify options to determine how the imported text is formatted.

1. Do one of the following:

   a. To create a new frame for the placed text, make sure that no insertion point is present and that no text or frames are selected.

   b. To add text to a frame, use the “Type” tool to select text or place the insertion point.

   c. To replace the contents of an existing frame, use a selection tool to select the frame. If the frame is threaded, a loaded text cursor appears.

2. Choose “File > Place.”

3. Select “Replace Selected Item” if you want the imported file to replace the contents of a selected frame, to replace selected text, or to be added to the text
frame at the insertion point. Deselect this option to flow the imported file into a new frame.

4. Select “Show Import Options,” and then double-click the file you want to import.

5. Set import options, and then click “OK”.

6. If you haven’t already designated an existing frame to receive text, the pointer becomes a loaded text icon, ready to flow text wherever you click or drag.

**Thread Text Frames**

The text in a frame can be independent of other frames, or it can flow between connected frames. To flow text between connected frames (also called text boxes), you must first connect the frames. Connected frames can be on the same page or spread, or on another page in the document. The process of connecting text among frames is called **threading text**. It is also referred to as **linking text frames** or **linking text boxes**.

**Add a new frame to the thread**

1. Using the “Selection” tool, select a text frame, and then click the “In Port” or “Out Port” to load a text icon. Clicking the “In Port” lets you add a frame before the selected frame; clicking the “Out Port” lets you add a frame after the selected frame.

2. Position the loaded text icon where you want a new text frame to appear, and then click or drag to create a new text frame.
**Add an existing frame to the thread**

1. Using the “Selection” tool, select a text frame, and then click the “In Port” or the “Out Port” to load a text icon.

2. Position the loaded text icon over the frame you want to connect to. The loaded text icon changes to the thread icon.

3. Click inside the second frame to thread it to the first.

**Flow Text Manually or Automatically**

**Flow text manually**

1. Use the “Place” command to select a file, or click the “Out Port” of a selected text frame.

2. Do one of the following:
   
   a. Position the loaded text icon anywhere within an existing frame or path, and then click. The text flows into the frame and any other frames linked to it. Note that text always starts filling the frame at the top of the leftmost column, even when you click in a different column.

   b. Position the loaded text icon in a column to create a text frame the width of that column. The top of the frame appears where you click.

   c. Drag the loaded text icon to create a text frame the width and height of the area you define.

3. If there is more text to be placed, click the out port and repeat steps 1 and 2 until all text has been placed.
Flow text semi-automatically

With a loaded text icon, “Alt-click” (Windows) or “Option-click” (Mac OS) a page or frame. The text flows one column at a time, as in manual flow, but the loaded text icon automatically reloads after each column is placed.

Flow text automatically

With the loaded text icon displayed, hold down “Shift” as you do one of the following:

- Click the loaded text icon in a column to create a frame the width of that column. InDesign creates new text frames and new document pages until all text is added to the document.
- Click inside a text frame that is based on a master text frame. The text autoflows into the document page frame and generates new pages as needed, using the master frame’s attributes.

Flow text automatically without adding pages

With a loaded text icon, hold down “Shift+Alt” (Windows) or “Shift+Option” (Mac OS).

Wrap Text around Simple Objects

1. To display the “Text Wrap” panel, choose “Window > Text Wrap.”
2. Using the “Selection” tool or “Direct Selection” tool, select the object you want to wrap text around.
3. In the “Text Wrap” panel, click the desired wrap shape:
   a. “Wrap Around Bounding Box” creates a rectangular wrap whose width and height are determined by the bounding box of the selected object, including any offset distances you specify.
   b. “Wrap Around Object Shape” creates a text wrap boundary that is the same shape as the frame you’ve selected (plus or minus any offset distances you specify).
   c. “Jump Object” keeps text from appearing in any available space to the right or left of the frame.
   d. Jump To Next Column forces the surrounding paragraph to the top of the next column or text frame.
4. Specify offset values. Positive values move the wrap away from the frame; negative values move the wrap within the frame.

Create an Inverted Text Wrap

1. Using the “Selection” tool or “Direct Selection” tool, select an object that will allow text to wrap inside it.

2. To display the “Text Wrap” panel, choose “Window > Text Wrap.”

3. Apply a text wrap to an object, and select the Invert option. Invert is commonly used with the “Object Shape” text wrap.

Import Graphics

InDesign supports a variety of graphics formats, including bitmap formats such as TIFF, GIF, JPEG, and BMP, and vector formats such as EPS. Other supported formats include DCS, PICT, WMF, EMF, PCX, PNG, and Scitex CT (.sct). You can import an SWF file as a movie file.

Place (import) Graphics

The “Place” command is the primary method used to insert graphics into InDesign because it provides the highest level of support for resolution, file formats, multipage PDF and INDD files, and color. To place a graphics,

1. Do one of the following:
   • To import a graphic without first creating a frame, make sure that nothing in the document is selected.
   • To import a graphic into an existing frame, select the frame. If the new image is larger than the frame, you can refit the frame later by choosing Object > Fitting > [fitting command].
   • To replace an existing image, select its graphics frame.

2. Choose “File > Place” and select one or more graphics files of any available format. If you select multiple files, you can click or drag in the document to place the selected files one at a time.

3. To replace an object you selected, select “Replace Selected Item”.
4. To add a caption based on the image metadata, select “Create Static Captions”.

5. To set format-specific import options, do one of the following:
   - Select “Show Import Options”, and then click “Open”.
   - Hold down “Shift” as you click “Open” or “Shift-double-click” a file name.

6. If the “Image Import Options” dialog box appears (because you chose to set format-specific import options), select import options and click “OK”.

7. Do one of the following:
   - To import into a new frame, drag to create a frame. Or, click the loaded graphics icon in the layout at the place where you want the upper left corner of the graphic to appear.
   - To import into an existing, unselected frame, click the loaded graphics icon anywhere in that frame.
   - To import into an existing selected frame, you don’t need to do anything if “Replace Selected Item” is selected. The image automatically appears in that frame.
   - To replace an existing graphic, hold down “Alt” (Windows) or “Option” (Mac OS) and click the loaded graphics icon on the graphic you want to replace.

8. To place the next graphic, click the loaded graphics icon in the layout where desired.

**Place Multiple Graphics.**

The “Place” command lets you import more than one item at a time.

1. Create frames for the graphics if you want to place some or all of them in frames.

2. Choose “File > Place”, and select files. Hold down the “Ctrl” key to select multiple graphics.

3. Optionally, select “Show Import Options”, click “Open”, and specify the import options for each file. A thumbnail image of the first graphic you selected appears
next to the loaded graphics icon. A number next to the loaded graphics icon tells you how many graphics are ready for importing.

4. Do one of the following:

   • To import into a new frame, click the loaded graphics icon where you want the upper left corner of the graphic to appear.
   • To create a frame of a certain size and import the graphic into the frame, drag to define the frame. The frame conforms to the proportions of the graphic being placed.
   • To import into an existing frame, click the loaded graphics icon in the frame. “Alt-click” (Windows) or “Option-click” (Mac OS) to replace the contents of an existing frame.
   • To import all the loaded graphics in a grid, start dragging, and press the arrow keys to determine the number of rows and columns. Use the “Up Arrow” and “Down Arrow” keys to change the number of rows and the “Left Arrow” and “Right Arrow” keys to change the number of columns. Release the mouse button to place the grid of images. To change the spacing between frames, press “Page Up” or “Page Down” or hold down “Ctrl” (Windows) or “Command” (Mac OS) while pressing the arrow keys.

Wrap Text around Imported Images

To wrap text around an imported image, save the clipping path in the application where you created the image, if possible. When you place the image in InDesign, select the “Apply Photoshop Clipping Path” option in the “Image Import Options” dialog box.

1. To display the Text Wrap panel, choose “Window > Text Wrap”.

2. Select an imported image, and in the “Text Wrap” panel, click “Wrap Around Object Shape.”

3. Specify offset values. Positive values move the wrap away from the frame; negative values move the wrap within the frame.

4. From the “Type” menu, choose a contour option:

   a. “Bounding Box” wraps text to the rectangle formed by the image’s height and width.

   b. “Detect Edges” generates the boundary using automatic edge detection. (To adjust edge detection, select the object and choose “Object > Clipping Path > Options”.)
c. **“Alpha Channel”** generates the boundary from an alpha channel saved with the image. If this option isn’t available, no alpha channels were saved with the image. InDesign recognizes the default transparency in Adobe Photoshop (the checkerboard pattern) as an alpha channel; you must otherwise use Photoshop to delete the background or create and save one or more alpha channels with the image.

d. **“Photoshop Path”** generates the boundary from a path saved with the image. Choose Photoshop Path, and then choose a path from the Path menu. If the Photoshop Path option isn’t available, no named paths were saved with the image.

e. **“Graphic Frame”** generates the boundary from the container frame.

f. **“Same As Clipping”** generates the boundary from the imported image’s clipping path.

5. To let text appear inside “holes” of an image, select “Include Inside Edges”. 
Export Document

To export a document, select “File >> Export.”

Exporting content for the web

To repurpose InDesign content for the web, you have several options:

- **Dreamweaver (XHTML).** Export a selection or the entire document to a basic, unformatted HTML document. You can link to images on a server or create a separate folder for images. You can then use any HTML editor, such as Adobe Dreamweaver®, to format the content for the web.

- **HTML.** Exporting to HTML is an easy way to get your InDesign content into web-ready form. When you export content to HTML, you can control how text and images are exported. InDesign preserves the names of paragraph, character, object, table, and cell styles applied to the exported contents by marking the HTML contents with CSS style classes of the same name. Using Adobe Dreamweaver or any CSS-capable HTML editor, you can quickly apply formatting and layout to the contents.

- **Adobe PDF.** Export a document to Adobe PDF and post the PDF on the web. The PDF can include interactive elements such as movies, sound clips, buttons, and page transitions.

- **Flash (SWF).** Export to a SWF file that’s ready to be viewed immediately in Flash Player or on the web. A SWF file can include buttons, hyperlinks, and page transitions such as wipe, dissolve, and page curl.

- **Flash (FLA).** Export to a FLA file that can be edited in Adobe Flash Professional.

- **Digital Editions (EPUB).** Export a document or book as a reflowable XHTML-based eBook that is compatible with the Adobe Digital Editions reader software.

- **XML.** For advanced repurposing workflows, export the content from InDesign in XML format, which you can then import into an HTML editor such as Dreamweaver.